<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="x-ua-compatible" content="ie=edge"/><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"/><style data-href="/styles.aa6afcc8dd6cf3e5302d.css">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</style><meta name="generator" content="Gatsby 2.21.9"/><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-NVBMVX8');</script><title data-react-helmet="true">Ardalis is Steve Smith - ardalis</title><link data-react-helmet="true" rel="alternate" type="application/rss+xml" title="RSS Feed for Ardalis" href="/rss.xml/"/><link data-react-helmet="true" rel="apple-touch-icon" sizes="180x180" href="/img/apple-touch-icon.png"/><link data-react-helmet="true" rel="icon" type="image/png" href="/img/favicon-32x32.png" sizes="32x32"/><link data-react-helmet="true" rel="icon" type="image/png" href="/img/favicon-16x16.png" sizes="16x16"/><link data-react-helmet="true" rel="mask-icon" href="/img/safari-pinned-tab.svg" color="#ff4400"/><meta data-react-helmet="true" name="description" content="Steve is an experienced software architect and trainer, focusing currently on ASP.NET Core and Domain-Driven Design."/><meta data-react-helmet="true" name="theme-color" content="#fff"/><meta data-react-helmet="true" property="og:type" content="business.business"/><meta data-react-helmet="true" property="og:title" content="Ardalis is Steve Smith - ardalis"/><meta data-react-helmet="true" property="og:url" content="/"/><meta data-react-helmet="true" property="og:image" content="/img/og-image.jpg"/><link rel="sitemap" type="application/xml" href="/sitemap.xml"/><style id="jss-server-side"></style><link rel="alternate" type="application/rss+xml" title="Ardalis RSS Feed" href="/rss.xml"/><link as="script" rel="preload" href="/webpack-runtime-7554510bd23d95c749a3.js"/><link as="script" rel="preload" href="/framework-0748611d632b25c22642.js"/><link as="script" rel="preload" href="/532a2f07-5faf1395916999ba184f.js"/><link as="script" rel="preload" href="/app-c681a4e5e256acabb652.js"/><link as="script" rel="preload" href="/styles-8636a280cbc61d53ad10.js"/><link as="script" rel="preload" href="/29107295-f578dae5c0b5122ec5a9.js"/><link as="script" rel="preload" href="/commons-f60d9c3aa7db7a301ee5.js"/><link as="script" rel="preload" href="/a79c6e71bbaee2c8d4a978f98e689fac3998bb31-b339ea14ccf93500a9ad.js"/><link as="script" rel="preload" href="/component---src-templates-blog-list-js-8546a28acc9495a368c8.js"/><link as="fetch" rel="preload" href="/page-data/blog/page/156/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous"/></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NVBMVX8" height="0" width="0" style="display: none; visibility: hidden"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div><nav class="navbar is-transparent" role="navigation" aria-label="main-navigation"><div class="container"><div class="navbar-brand"><a class="navbar-item" title="Logo" href="/"><img src="data:image/png;base64,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" alt="Ardalis" style="width:150px"/></a><div class="navbar-burger burger " data-target="navMenu" role="button" tabindex="0"><span></span><span></span><span></span></div></div><div id="navMenu" class="navbar-menu "><div class="navbar-start has-text-centered"><a class="navbar-item" href="/blog">Blog</a><a class="navbar-item" href="/training-classes">Training</a><a class="navbar-item" href="/mentoring">Mentoring</a><a class="navbar-item" href="/tips">Dev Tips</a><a class="navbar-item" href="/architecture-ebook">Architecture eBook</a><a class="navbar-item" href="/tools-used">Tools Used</a><a class="navbar-item" href="/contact-us">Contact</a></div><div class="navbar-end has-text-centered"><a class="navbar-item" href="https://www.facebook.com/StevenAndrewSmith" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHZpZXdCb3g9IjAgMCAyNCAyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj48dGl0bGU+RmFjZWJvb2sgaWNvbjwvdGl0bGU+PHBhdGggZD0iTTIyLjY3NiAwSDEuMzI0Qy41OTMgMCAwIC41OTMgMCAxLjMyNHYyMS4zNTJDMCAyMy40MDguNTkzIDI0IDEuMzI0IDI0aDExLjQ5NHYtOS4yOTRIOS42ODl2LTMuNjIxaDMuMTI5VjguNDFjMC0zLjA5OSAxLjg5NC00Ljc4NSA0LjY1OS00Ljc4NSAxLjMyNSAwIDIuNDY0LjA5NyAyLjc5Ni4xNDF2My4yNGgtMS45MjFjLTEuNSAwLTEuNzkyLjcyMS0xLjc5MiAxLjc3MXYyLjMxMWgzLjU4NGwtLjQ2NSAzLjYzSDE2LjU2VjI0aDYuMTE1Yy43MzMgMCAxLjMyNS0uNTkyIDEuMzI1LTEuMzI0VjEuMzI0QzI0IC41OTMgMjMuNDA4IDAgMjIuNjc2IDAiLz48L3N2Zz4=" alt="facebook"/></span></a><a class="navbar-item" href="https://www.linkedin.com/in/stevenandrewsmith" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHZpZXdCb3g9IjAgMCAyNCAyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj48dGl0bGU+TGlua2VkSW4gaWNvbjwvdGl0bGU+PHBhdGggZD0iTTIwLjQ0NyAyMC40NTJoLTMuNTU0di01LjU2OWMwLTEuMzI4LS4wMjctMy4wMzctMS44NTItMy4wMzctMS44NTMgMC0yLjEzNiAxLjQ0NS0yLjEzNiAyLjkzOXY1LjY2N0g5LjM1MVY5aDMuNDE0djEuNTYxaC4wNDZjLjQ3Ny0uOSAxLjYzNy0xLjg1IDMuMzctMS44NSAzLjYwMSAwIDQuMjY3IDIuMzcgNC4yNjcgNS40NTV2Ni4yODZ6TTUuMzM3IDcuNDMzYy0xLjE0NCAwLTIuMDYzLS45MjYtMi4wNjMtMi4wNjUgMC0xLjEzOC45Mi0yLjA2MyAyLjA2My0yLjA2MyAxLjE0IDAgMi4wNjQuOTI1IDIuMDY0IDIuMDYzIDAgMS4xMzktLjkyNSAyLjA2NS0yLjA2NCAyLjA2NXptMS43ODIgMTMuMDE5SDMuNTU1VjloMy41NjR2MTEuNDUyek0yMi4yMjUgMEgxLjc3MUMuNzkyIDAgMCAuNzc0IDAgMS43Mjl2MjAuNTQyQzAgMjMuMjI3Ljc5MiAyNCAxLjc3MSAyNGgyMC40NTFDMjMuMiAyNCAyNCAyMy4yMjcgMjQgMjIuMjcxVjEuNzI5QzI0IC43NzQgMjMuMiAwIDIyLjIyMiAwaC4wMDN6Ii8+PC9zdmc+" alt="linkedin"/></span></a><a class="navbar-item" href="https://twitter.com/ardalis" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,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" alt="twitter"/></span></a><a class="navbar-item" href="https://www.youtube.com/ardalis/" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmlld0JveD0iMCAwIDI0IDI0Ij48dGl0bGU+WW91VHViZSBpY29uPC90aXRsZT48cGF0aCBkPSJNMjMuNDk1IDYuMjA1YTMuMDA3IDMuMDA3IDAgMCAwLTIuMDg4LTIuMDg4Yy0xLjg3LS41MDEtOS4zOTYtLjUwMS05LjM5Ni0uNTAxcy03LjUwNy0uMDEtOS4zOTYuNTAxQTMuMDA3IDMuMDA3IDAgMCAwIC41MjcgNi4yMDVhMzEuMjQ3IDMxLjI0NyAwIDAgMC0uNTIyIDUuODA1IDMxLjI0NyAzMS4yNDcgMCAwIDAgLjUyMiA1Ljc4MyAzLjAwNyAzLjAwNyAwIDAgMCAyLjA4OCAyLjA4OGMxLjg2OC41MDIgOS4zOTYuNTAyIDkuMzk2LjUwMnM3LjUwNiAwIDkuMzk2LS41MDJhMy4wMDcgMy4wMDcgMCAwIDAgMi4wODgtMi4wODggMzEuMjQ3IDMxLjI0NyAwIDAgMCAuNS01Ljc4MyAzMS4yNDcgMzEuMjQ3IDAgMCAwLS41LTUuODA1ek05LjYwOSAxNS42MDFWOC40MDhsNi4yNjQgMy42MDJ6Ii8+PC9zdmc+" alt="youtube"/></span></a><a class="navbar-item" href="https://github.com/ardalis" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,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" alt="Github"/></span></a></div></div></div></nav><div><div class="full-width-image-container margin-top-0" style="background-image:url(&#x27;/img/blogging.jpg&#x27;)"><h1 class="has-text-weight-bold is-size-1" style="box-shadow:0.5rem 0 0 #3571B8, -0.5rem 0 0 #3571B8;background-color:rgba(53, 113, 184, 0.59);color:white;padding:1rem">Latest Articles</h1></div><section class="section"><div class="container"><div class="tile is-ancestor"><div class="tile is-vertical is-7"><div class="tile"><div class="tile is-parent"><article class="tile is-child box"><div class="content"><div class="columns is-multiline"></div><ul style="display:flex;flex-wrap:wrap;margin-bottom:2rem;margin-top:2rem;align-items:center;list-style:none;padding:0;margin-left:0%"><a rel="prev" href="/blog/page/155">← Previous Page</a><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog">1</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/2">2</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/3">3</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/4">4</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/5">5</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/6">6</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/7">7</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/8">8</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/9">9</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/10">10</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/11">11</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/12">12</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/13">13</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/14">14</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/15">15</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/16">16</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/17">17</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/18">18</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/19">19</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/20">20</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/21">21</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/22">22</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/23">23</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/24">24</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/25">25</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/26">26</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/27">27</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/28">28</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/29">29</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/30">30</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/31">31</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/32">32</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/33">33</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/34">34</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/35">35</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/36">36</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/37">37</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/38">38</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/39">39</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/40">40</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/41">41</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/42">42</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/43">43</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/44">44</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/45">45</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/46">46</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/47">47</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/48">48</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/49">49</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/50">50</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/51">51</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/52">52</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/53">53</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/54">54</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/55">55</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/56">56</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/57">57</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/58">58</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/59">59</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/60">60</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/61">61</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/62">62</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/63">63</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/64">64</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/65">65</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/66">66</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/67">67</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/68">68</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/69">69</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/70">70</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/71">71</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/72">72</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/73">73</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/74">74</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/75">75</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/76">76</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/77">77</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/78">78</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/79">79</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/80">80</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/81">81</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/82">82</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/83">83</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/84">84</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/85">85</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/86">86</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/87">87</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/88">88</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/89">89</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/90">90</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/91">91</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/92">92</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/93">93</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/94">94</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/95">95</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/96">96</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/97">97</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/98">98</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/99">99</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/100">100</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/101">101</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/102">102</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/103">103</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/104">104</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/105">105</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/106">106</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/107">107</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/108">108</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/109">109</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/110">110</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/111">111</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/112">112</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/113">113</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/114">114</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/115">115</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/116">116</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/117">117</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/118">118</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/119">119</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/120">120</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/121">121</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/122">122</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/123">123</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/124">124</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/125">125</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/126">126</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/127">127</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/128">128</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/129">129</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/130">130</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/131">131</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/132">132</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/133">133</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/134">134</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/135">135</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/136">136</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/137">137</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/138">138</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/139">139</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/140">140</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/141">141</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/142">142</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/143">143</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/144">144</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/145">145</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/146">146</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/147">147</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/148">148</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/149">149</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/150">150</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/151">151</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/152">152</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/153">153</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/154">154</a></li><li style="margin:0"><a style="padding:0.42rem;text-decoration:none;color:;background:" href="/blog/page/155">155</a></li><li style="margin:0"><a aria-current="page" style="padding:0.42rem;text-decoration:none;color:#ffffff;background:#007acc" class="" href="/blog/page/156">156</a></li></ul></div></article></div></div></div><div><header><div><div class="tile is-parent"><article class="tile is-child box"><div class="sidebar"><div class="content has-text-centered"><div class="content-card"><div class="card-sidebar"><div class="firstinfo"><img src="/static/steve-smith-ardalis-200x200-1530d4270a51c90fda39512d123c2aef.jpg" alt="Steve Smith"/><div class="profileinfo"><h1>About Ardalis</h1><h3>Software Architect</h3><p class="bio">Steve is an experienced software architect and trainer, focusing on code quality and Domain-Driven Design with .NET.</p></div></div></div></div></div><div><h4 style="padding:8px;margin-left:10px"><a href="/tips">Sign up</a> to receive a free developer tip from Steve in your inbox every Wednesday.</h4><br/></div><div><h2 style="font-size:22px;padding:7px;margin-left:15px;font-weight:BOLD"><span role="img" aria-label="graduation cap">🎓</span> ONLINE TRAINING</h2></div> <br/><div class="recent-post"><ul class="recent-post"><li><a href="https://www.pluralsight.com/courses/domain-driven-design-fundamentals">Domain-Driven Design Fundamentals</a></li><li><a href="https://www.pluralsight.com/courses/refactoring-csharp-developers">Refactoring for C# Devs</a></li><li><a href="https://www.pluralsight.com/courses/kanban-fundamentals">Kanban Fundamentals</a></li><li><a href="https://www.pluralsight.com/courses/csharp-solid-principles">SOLID Principles of OO Design</a></li><li><a href="https://www.pluralsight.com/courses/design-patterns-overview">Design Patterns Overview</a></li></ul></div> <br/><div class="recent-post"><h2 style="font-size:22px;padding:7px;font-weight:BOLD"><span role="img" aria-label="clipboard">📋</span> CATEGORIES</h2> <br/><ul class="recent-post" style="text-transform:uppercase"><li><a href="/category/iraq/">Iraq<!-- --> (<!-- -->119<!-- -->)</a></li><li><a href="/category/personal/">Personal<!-- --> (<!-- -->21<!-- -->)</a></li><li><a href="/category/productivity/">Productivity<!-- --> (<!-- -->112<!-- -->)</a></li><li><a href="/category/security/">Security<!-- --> (<!-- -->6<!-- -->)</a></li><li><a href="/category/software-development/">Software Development<!-- --> (<!-- -->635<!-- -->)</a></li><li><a href="/category/uncategorized/">Uncategorized<!-- --> (<!-- -->694<!-- -->)</a></li></ul> </div><div><br/><h4 style="font-size:22px;padding:7px;margin-left:15px;font-weight:BOLD"><span role="img" aria-label="book">📘</span> FREE ARCHITECTURE EBOOK</h4><br/><center><a href="/tips"><img src="/static/Architecture-eBook-Cover-242x300-f5137e850ecde6e104d5b043645cd6b0.png" alt="book"/></a><h4><a href="/tips">Get the Book!</a></h4></center><br/><h1 style="font-size:22px;padding:7px;margin-left:15px;font-weight:BOLD"><span role="img" aria-label="pen">🖊️</span> RECENT ARTICLES</h1><br/><div class="columns is-multiline"><div><article><header><div class="recent-post"><ul class="recent-post"><li><a href="/run-docker-rabbitmq-command-streamdeck/">Run a Docker Command to Launch RabbitMQ from a StreamDeck</a></li></ul></div></header></article></div><div><article><header><div class="recent-post"><ul class="recent-post"><li><a href="/hardware-hides-many-sins/">Hardware Hides Many Sins</a></li></ul></div></header></article></div><div><article><header><div class="recent-post"><ul class="recent-post"><li><a href="/new-software-project-checklist/">New Software Project Checklist</a></li></ul></div></header></article></div><div><article><header><div class="recent-post"><ul class="recent-post"><li><a href="/related-data-without-foreign-keys/">Designing for Related Data without Foreign Keys</a></li></ul></div></header></article></div><div><article><header><div class="recent-post"><ul class="recent-post"><li><a href="/dto-or-poco/">What is the difference between a DTO and a POCO (or POJO)</a></li></ul></div></header></article></div></div><br/><h1 style="font-size:22px;padding:7px;margin-left:15px;font-weight:BOLD"><span role="img" aria-label="bird">🐦</span> RECENT TWEETS</h1><a class="twitter-timeline" data-width="400" data-height="800" data-theme="light" href="https://twitter.com/ardalis?ref_src=twsrc%5Etfw" data-chrome="noscrollbar">Tweets by ardalis</a><script async="" src="https://platform.twitter.com/widgets.js" charSet="utf-8" type="text/javascript"></script></div><div></div></div></article></div></div></header></div></div></div></section></div><footer class="footer has-background-black has-text-white-ter"><div class="content has-text-centered has-background-black has-text-white-ter"><div class="container has-background-black has-text-white-ter"><div class="columns"><div class="column is-4"><form action="https://www.google.com/search" method="get"><input type="hidden" name="q" value="site:ardalis.com"/><input type="text" name="q" alt="search" class="googletextbox"/><input type="submit" value="Search my Site with Google" class="googletextbox"/></form><br/></div><div class="column is-4"><div class="content has-text-centered"><img src="data:image/png;base64,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" alt="Ardalis" style="width:5em;height:5em"/><p>Copyright © 2021</p><br/></div></div><div class="column is-4 social"><a title="facebook" href="https://www.facebook.com/StevenAndrewSmith"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHZpZXdCb3g9IjAgMCAyNCAyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj48dGl0bGU+RmFjZWJvb2sgaWNvbjwvdGl0bGU+PHBhdGggZD0iTTIyLjY3NiAwSDEuMzI0Qy41OTMgMCAwIC41OTMgMCAxLjMyNHYyMS4zNTJDMCAyMy40MDguNTkzIDI0IDEuMzI0IDI0aDExLjQ5NHYtOS4yOTRIOS42ODl2LTMuNjIxaDMuMTI5VjguNDFjMC0zLjA5OSAxLjg5NC00Ljc4NSA0LjY1OS00Ljc4NSAxLjMyNSAwIDIuNDY0LjA5NyAyLjc5Ni4xNDF2My4yNGgtMS45MjFjLTEuNSAwLTEuNzkyLjcyMS0xLjc5MiAxLjc3MXYyLjMxMWgzLjU4NGwtLjQ2NSAzLjYzSDE2LjU2VjI0aDYuMTE1Yy43MzMgMCAxLjMyNS0uNTkyIDEuMzI1LTEuMzI0VjEuMzI0QzI0IC41OTMgMjMuNDA4IDAgMjIuNjc2IDAiLz48L3N2Zz4=" alt="Facebook" style="width:1em;height:1em"/></a><a title="linkedin" href="https://www.linkedin.com/in/stevenandrewsmith"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHZpZXdCb3g9IjAgMCAyNCAyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj48dGl0bGU+TGlua2VkSW4gaWNvbjwvdGl0bGU+PHBhdGggZD0iTTIwLjQ0NyAyMC40NTJoLTMuNTU0di01LjU2OWMwLTEuMzI4LS4wMjctMy4wMzctMS44NTItMy4wMzctMS44NTMgMC0yLjEzNiAxLjQ0NS0yLjEzNiAyLjkzOXY1LjY2N0g5LjM1MVY5aDMuNDE0djEuNTYxaC4wNDZjLjQ3Ny0uOSAxLjYzNy0xLjg1IDMuMzctMS44NSAzLjYwMSAwIDQuMjY3IDIuMzcgNC4yNjcgNS40NTV2Ni4yODZ6TTUuMzM3IDcuNDMzYy0xLjE0NCAwLTIuMDYzLS45MjYtMi4wNjMtMi4wNjUgMC0xLjEzOC45Mi0yLjA2MyAyLjA2My0yLjA2MyAxLjE0IDAgMi4wNjQuOTI1IDIuMDY0IDIuMDYzIDAgMS4xMzktLjkyNSAyLjA2NS0yLjA2NCAyLjA2NXptMS43ODIgMTMuMDE5SDMuNTU1VjloMy41NjR2MTEuNDUyek0yMi4yMjUgMEgxLjc3MUMuNzkyIDAgMCAuNzc0IDAgMS43Mjl2MjAuNTQyQzAgMjMuMjI3Ljc5MiAyNCAxLjc3MSAyNGgyMC40NTFDMjMuMiAyNCAyNCAyMy4yMjcgMjQgMjIuMjcxVjEuNzI5QzI0IC43NzQgMjMuMiAwIDIyLjIyMiAwaC4wMDN6Ii8+PC9zdmc+" alt="Linkedin" style="width:1em;height:1em"/></a><a title="twitter" href="https://twitter.com/ardalis"><img class="fas fa-lg" src="data:image/svg+xml;base64,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" alt="Twitter" style="width:1em;height:1em"/></a><a title="youtube" href="https://www.youtube.com/ardalis/"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmlld0JveD0iMCAwIDI0IDI0Ij48dGl0bGU+WW91VHViZSBpY29uPC90aXRsZT48cGF0aCBkPSJNMjMuNDk1IDYuMjA1YTMuMDA3IDMuMDA3IDAgMCAwLTIuMDg4LTIuMDg4Yy0xLjg3LS41MDEtOS4zOTYtLjUwMS05LjM5Ni0uNTAxcy03LjUwNy0uMDEtOS4zOTYuNTAxQTMuMDA3IDMuMDA3IDAgMCAwIC41MjcgNi4yMDVhMzEuMjQ3IDMxLjI0NyAwIDAgMC0uNTIyIDUuODA1IDMxLjI0NyAzMS4yNDcgMCAwIDAgLjUyMiA1Ljc4MyAzLjAwNyAzLjAwNyAwIDAgMCAyLjA4OCAyLjA4OGMxLjg2OC41MDIgOS4zOTYuNTAyIDkuMzk2LjUwMnM3LjUwNiAwIDkuMzk2LS41MDJhMy4wMDcgMy4wMDcgMCAwIDAgMi4wODgtMi4wODggMzEuMjQ3IDMxLjI0NyAwIDAgMCAuNS01Ljc4MyAzMS4yNDcgMzEuMjQ3IDAgMCAwLS41LTUuODA1ek05LjYwOSAxNS42MDFWOC40MDhsNi4yNjQgMy42MDJ6Ii8+PC9zdmc+" alt="YoutTube" style="width:1em;height:1em"/></a><a title="github" href="https://github.com/ardalis"><img src="data:image/svg+xml;base64,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" alt="GitHub" style="width:1em;height:1em"/></a></div></div><div class="columns"><div class="column is-12"> <br/></div></div></div></div></footer></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/blog/page/156";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"app":["/app-c681a4e5e256acabb652.js"],"component---src-pages-404-js":["/component---src-pages-404-js-ddfbc22bda9e3979c612.js"],"component---src-pages-blog-xxindex-js":["/component---src-pages-blog-xxindex-js-f7dba0ae668b6a007fea.js"],"component---src-pages-category-index-js":["/component---src-pages-category-index-js-6217348e7d5d481d7b20.js"],"component---src-pages-contact-us-index-js":["/component---src-pages-contact-us-index-js-78660a3b70d1b17e6445.js"],"component---src-pages-contact-us-thanks-js":["/component---src-pages-contact-us-thanks-js-10ce3a08bf20bfc8f527.js"],"component---src-pages-tags-index-js":["/component---src-pages-tags-index-js-49a00d704fde959c7352.js"],"component---src-templates-architecture-ebook-page-js":["/component---src-templates-architecture-ebook-page-js-9f2bdf54ab3d8d521b06.js"],"component---src-templates-assessments-page-js":["/component---src-templates-assessments-page-js-06a2359441d090e15a3b.js"],"component---src-templates-blog-list-js":["/component---src-templates-blog-list-js-8546a28acc9495a368c8.js"],"component---src-templates-blog-post-js":["/component---src-templates-blog-post-js-d6b38787520005ea6c42.js"],"component---src-templates-category-js":["/component---src-templates-category-js-9cdfc05fb7c9a0254b6a.js"],"component---src-templates-cloud-native-ebook-page-js":["/component---src-templates-cloud-native-ebook-page-js-80981fef5e9e04cf9052.js"],"component---src-templates-index-page-js":["/component---src-templates-index-page-js-690dd22b4ef7f383d57a.js"],"component---src-templates-interviews-page-js":["/component---src-templates-interviews-page-js-6b7488ecc1654d223594.js"],"component---src-templates-mentoring-page-js":["/component---src-templates-mentoring-page-js-994504de6ce8e096c225.js"],"component---src-templates-porting-ebook-page-js":["/component---src-templates-porting-ebook-page-js-57de8b32ef1c7ad72adc.js"],"component---src-templates-software-craftsmanship-2016-wall-calendar-sponsorship-page-js":["/component---src-templates-software-craftsmanship-2016-wall-calendar-sponsorship-page-js-8db4d98049fdcb9b0f88.js"],"component---src-templates-tags-js":["/component---src-templates-tags-js-3e613a14aa09dc5f2d38.js"],"component---src-templates-tips-page-js":["/component---src-templates-tips-page-js-a438c0143da9fb712e8b.js"],"component---src-templates-tools-used-page-js":["/component---src-templates-tools-used-page-js-b82d970539c5ffc77a0a.js"],"component---src-templates-training-classes-page-js":["/component---src-templates-training-classes-page-js-46aeb90eb5a6ac7ff49a.js"]};/*]]>*/</script><script src="/component---src-templates-blog-list-js-8546a28acc9495a368c8.js" async=""></script><script src="/a79c6e71bbaee2c8d4a978f98e689fac3998bb31-b339ea14ccf93500a9ad.js" async=""></script><script src="/commons-f60d9c3aa7db7a301ee5.js" async=""></script><script src="/29107295-f578dae5c0b5122ec5a9.js" async=""></script><script src="/styles-8636a280cbc61d53ad10.js" async=""></script><script src="/app-c681a4e5e256acabb652.js" async=""></script><script src="/532a2f07-5faf1395916999ba184f.js" async=""></script><script src="/framework-0748611d632b25c22642.js" async=""></script><script src="/webpack-runtime-7554510bd23d95c749a3.js" async=""></script></body></html>