<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="x-ua-compatible" content="ie=edge"/><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"/><style data-href="/styles.a4b7bfe3fc30cf5f6337.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 2.32.13"/><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-NVBMVX8');</script><title data-react-helmet="true">GitHub Diagrams with Mermaid | Blog</title><link data-react-helmet="true" rel="alternate" type="application/rss+xml" title="RSS Feed for Ardalis" href="/rss.xml/"/><link data-react-helmet="true" rel="apple-touch-icon" sizes="180x180" href="/img/apple-touch-icon.png"/><link data-react-helmet="true" rel="icon" type="image/png" href="/img/favicon-32x32.png" sizes="32x32"/><link data-react-helmet="true" rel="icon" type="image/png" href="/img/favicon-16x16.png" sizes="16x16"/><link data-react-helmet="true" rel="mask-icon" href="/img/safari-pinned-tab.svg" color="#ff4400"/><meta data-react-helmet="true" name="theme-color" content="#fff"/><meta data-react-helmet="true" name="description" content="It&#x27;s often useful to include diagrams in GitHub documentation and README files. GitHub now natively supports the Mermaid diagram syntax, and will render the diagrams inline when markdown files include the syntax are viewed in the browser."/><meta data-react-helmet="true" name="image" content="https://ardalis.com/static/1b94f3e85b3fd5d8f9e2f1ca1320c3c0/4e530/github-diagrams-with-mermaid.png"/><meta data-react-helmet="true" property="og:type" content="blog"/><meta data-react-helmet="true" property="og:image:alt" content="GitHub Diagrams with Mermaid"/><meta data-react-helmet="true" property="og:locale" content="en_US"/><meta data-react-helmet="true" property="og:image" content="https://ardalis.com/static/1b94f3e85b3fd5d8f9e2f1ca1320c3c0/4e530/github-diagrams-with-mermaid.png"/><meta data-react-helmet="true" property="og:title" content="GitHub Diagrams with Mermaid"/><meta data-react-helmet="true" property="og:description" content="It&#x27;s often useful to include diagrams in GitHub documentation and README files. GitHub now natively supports the Mermaid diagram syntax, and will render the diagrams inline when markdown files include the syntax are viewed in the browser."/><meta data-react-helmet="true" property="og:url" content="https://ardalis.com/github-diagrams-with-mermaid/"/><meta data-react-helmet="true" property="og:site_name" content="https://ardalis.com"/><meta data-react-helmet="true" property="article:author" content="Ardalis"/><meta data-react-helmet="true" name="twitter:title" content="GitHub Diagrams with Mermaid"/><meta data-react-helmet="true" name="twitter:url" content="https://ardalis.com/github-diagrams-with-mermaid/"/><meta data-react-helmet="true" name="twitter:description" content="It&#x27;s often useful to include diagrams in GitHub documentation and README files. GitHub now natively supports the Mermaid diagram syntax, and will render the diagrams inline when markdown files include the syntax are viewed in the browser."/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:image" content="https://ardalis.com/static/1b94f3e85b3fd5d8f9e2f1ca1320c3c0/4e530/github-diagrams-with-mermaid.png"/><link rel="sitemap" type="application/xml" href="/sitemap.xml"/><style id="jss-server-side"></style><link as="script" rel="preload" href="/webpack-runtime-36388a63b41a7b41a875.js"/><link as="script" rel="preload" href="/framework-c50c4d43c442b0cfdcd1.js"/><link as="script" rel="preload" href="/532a2f07-4651461872a907e7c236.js"/><link as="script" rel="preload" href="/app-d43e6fbc0230c1f5e888.js"/><link as="script" rel="preload" href="/styles-407fe62976dc5310c43e.js"/><link as="script" rel="preload" href="/commons-1b32abe377a591af7778.js"/><link as="script" rel="preload" href="/4b5a68188bb98d13639e995513dba2341ec16632-9fd23cd94eed459f68d1.js"/><link as="script" rel="preload" href="/component---src-templates-blog-post-js-048f5413cb1fff10b611.js"/><link as="fetch" rel="preload" href="/page-data/github-diagrams-with-mermaid/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/1354573263.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/2911710822.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/4080856488.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous"/></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NVBMVX8" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div><nav class="navbar is-transparent" role="navigation" aria-label="main-navigation"><div class="container"><div class="navbar-brand"><a class="navbar-item" title="Logo" href="/"><img src="data:image/png;base64,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" alt="Ardalis" style="width:150px"/></a><div class="navbar-burger burger " data-target="navMenu" role="button" tabindex="0"><span></span><span></span><span></span></div></div><div id="navMenu" class="navbar-menu "><div class="navbar-start has-text-centered"><a class="navbar-item" href="/blog">Blog</a><a class="navbar-item" href="/training-classes">Training</a><a class="navbar-item" href="/mentoring">Mentoring</a><a class="navbar-item" href="/tips">Dev Tips</a><a class="navbar-item" href="/architecture-ebook">Architecture eBook</a><a class="navbar-item" href="/tools-used">Tools Used</a><a class="navbar-item" href="/contact-us">Contact</a></div><div class="navbar-end has-text-centered"><a class="navbar-item" href="https://www.facebook.com/StevenAndrewSmith" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHZpZXdCb3g9IjAgMCAyNCAyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj48dGl0bGU+RmFjZWJvb2sgaWNvbjwvdGl0bGU+PHBhdGggZD0iTTIyLjY3NiAwSDEuMzI0Qy41OTMgMCAwIC41OTMgMCAxLjMyNHYyMS4zNTJDMCAyMy40MDguNTkzIDI0IDEuMzI0IDI0aDExLjQ5NHYtOS4yOTRIOS42ODl2LTMuNjIxaDMuMTI5VjguNDFjMC0zLjA5OSAxLjg5NC00Ljc4NSA0LjY1OS00Ljc4NSAxLjMyNSAwIDIuNDY0LjA5NyAyLjc5Ni4xNDF2My4yNGgtMS45MjFjLTEuNSAwLTEuNzkyLjcyMS0xLjc5MiAxLjc3MXYyLjMxMWgzLjU4NGwtLjQ2NSAzLjYzSDE2LjU2VjI0aDYuMTE1Yy43MzMgMCAxLjMyNS0uNTkyIDEuMzI1LTEuMzI0VjEuMzI0QzI0IC41OTMgMjMuNDA4IDAgMjIuNjc2IDAiLz48L3N2Zz4=" alt="facebook"/></span></a><a class="navbar-item" href="https://www.linkedin.com/in/stevenandrewsmith" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHZpZXdCb3g9IjAgMCAyNCAyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj48dGl0bGU+TGlua2VkSW4gaWNvbjwvdGl0bGU+PHBhdGggZD0iTTIwLjQ0NyAyMC40NTJoLTMuNTU0di01LjU2OWMwLTEuMzI4LS4wMjctMy4wMzctMS44NTItMy4wMzctMS44NTMgMC0yLjEzNiAxLjQ0NS0yLjEzNiAyLjkzOXY1LjY2N0g5LjM1MVY5aDMuNDE0djEuNTYxaC4wNDZjLjQ3Ny0uOSAxLjYzNy0xLjg1IDMuMzctMS44NSAzLjYwMSAwIDQuMjY3IDIuMzcgNC4yNjcgNS40NTV2Ni4yODZ6TTUuMzM3IDcuNDMzYy0xLjE0NCAwLTIuMDYzLS45MjYtMi4wNjMtMi4wNjUgMC0xLjEzOC45Mi0yLjA2MyAyLjA2My0yLjA2MyAxLjE0IDAgMi4wNjQuOTI1IDIuMDY0IDIuMDYzIDAgMS4xMzktLjkyNSAyLjA2NS0yLjA2NCAyLjA2NXptMS43ODIgMTMuMDE5SDMuNTU1VjloMy41NjR2MTEuNDUyek0yMi4yMjUgMEgxLjc3MUMuNzkyIDAgMCAuNzc0IDAgMS43Mjl2MjAuNTQyQzAgMjMuMjI3Ljc5MiAyNCAxLjc3MSAyNGgyMC40NTFDMjMuMiAyNCAyNCAyMy4yMjcgMjQgMjIuMjcxVjEuNzI5QzI0IC43NzQgMjMuMiAwIDIyLjIyMiAwaC4wMDN6Ii8+PC9zdmc+" alt="linkedin"/></span></a><a class="navbar-item" href="https://twitter.com/ardalis" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,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" alt="twitter"/></span></a><a class="navbar-item" href="https://www.youtube.com/ardalis/" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmlld0JveD0iMCAwIDI0IDI0Ij48dGl0bGU+WW91VHViZSBpY29uPC90aXRsZT48cGF0aCBkPSJNMjMuNDk1IDYuMjA1YTMuMDA3IDMuMDA3IDAgMCAwLTIuMDg4LTIuMDg4Yy0xLjg3LS41MDEtOS4zOTYtLjUwMS05LjM5Ni0uNTAxcy03LjUwNy0uMDEtOS4zOTYuNTAxQTMuMDA3IDMuMDA3IDAgMCAwIC41MjcgNi4yMDVhMzEuMjQ3IDMxLjI0NyAwIDAgMC0uNTIyIDUuODA1IDMxLjI0NyAzMS4yNDcgMCAwIDAgLjUyMiA1Ljc4MyAzLjAwNyAzLjAwNyAwIDAgMCAyLjA4OCAyLjA4OGMxLjg2OC41MDIgOS4zOTYuNTAyIDkuMzk2LjUwMnM3LjUwNiAwIDkuMzk2LS41MDJhMy4wMDcgMy4wMDcgMCAwIDAgMi4wODgtMi4wODggMzEuMjQ3IDMxLjI0NyAwIDAgMCAuNS01Ljc4MyAzMS4yNDcgMzEuMjQ3IDAgMCAwLS41LTUuODA1ek05LjYwOSAxNS42MDFWOC40MDhsNi4yNjQgMy42MDJ6Ii8+PC9zdmc+" alt="youtube"/></span></a><a class="navbar-item" href="https://github.com/ardalis" target="_blank" rel="noopener noreferrer"><span class="icon"><img src="data:image/svg+xml;base64,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" alt="Github"/></span></a></div></div></div></nav><div><section class="section"><div class="full-width-image-container margin-top-0" style="background-image:url(/static/blogging-2ea6f6dbe2d1837d52e0efb834050909.jpg)"></div><div class="tile is-ancestor"><div class="tile is-vertical is-7"><div class="tile"><div class="tile is-parent"><article class="tile is-child box"><div class="container content"><div class="columns"><div class="column is-10 is-offset-1"><h1 class="title is-size-2 has-text-weight-bold is-bold-light">GitHub Diagrams with Mermaid</h1><p style="width:100%;font-weight:bold;color:#3571B8"> Date Published: <!-- -->16 February 2022</p><p><img src="/static/1b94f3e85b3fd5d8f9e2f1ca1320c3c0/4e530/github-diagrams-with-mermaid.png" alt="GitHub Diagrams with Mermaid" width="100%"/></p><div><p>GitHub recently announced support for diagrams embedded directly in markdown files. The new feature leverages the <a href="https://mermaid-js.github.io/mermaid/#/">Mermaid diagramming and charting tool</a>, which is JavaScript-based and supports many common diagram formats. I've solved this problem in other ways in the past and in this article I'll show how to get started using Mermaid in your GitHub projects and how it compares to other approaches.</p>
<h2>Using Mermaid in GitHub Markdown</h2>
<p>To get started using Mermaid all you need to do is create a code-fenced area using triple-backtick syntax and specify that your language is <code class="language-text">mermaid</code>. Then, you need to specify what kind of diagram you're creating on the first line. Some examples include:</p>
<ul>
<li>classDiagram</li>
<li>erDiagram</li>
<li>flowchart</li>
<li>gantt</li>
<li>graph</li>
<li>journey</li>
<li>pie</li>
<li>requirementDiagram</li>
<li>sequenceDiagram</li>
<li>stateDiagram-v2</li>
</ul>
<p>Once you've specified the <strong>diagram type</strong> you're then free to describe your diagram using a grammar specific to the type. Note that the syntax is <strong>not</strong> consistent between types, so if you know how to draw an arrow with a label using the <code class="language-text">flowchart</code> syntax, you'll find you'll need a different approach to perform the same task in a <code class="language-text">stateDiagram-v2</code> diagram.</p>
<p>Note that you can give hints to the diagram type like <code class="language-text">TB</code> for "Top to Bottom" using something like <code class="language-text">graph TB</code>. <code class="language-text">TD</code> is "Top Down" and is the same as <code class="language-text">TB</code>.</p>
<p>Although my blog is written in markdown, I haven't set up support for mermaid in it (yet), so the examples here will use screenshots. Below is an example sequence diagram from the <a href="https://mermaid-js.github.io/mermaid/#/sequenceDiagram?id=aliases">mermaid docs</a>:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 650px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/de0db7db9cc0d256a4a4ee123bf06ed9/01dae/mermaid-sequence-sample.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 72.39263803680981%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAOCAYAAAAvxDzwAAAACXBIWXMAAA7EAAAOxAGVKw4bAAAB70lEQVQ4y5VS207bQBD1bxD+qGrfq/Z/evmBChJcSIDgQAJVH4to1SiF3h4olQqUQhUESkiyJbZ3115fcrq7id2kkaN25NF4ZtbHZ+asEYYRLprXuLq+wWAwAOSjfYapc1luxHEMyji474F5HJ7vg1IG16VwHKp7rsydUS5EMPNnhqLDqQ+HyI8I19H3BMIwQBAMXYEIIXRUeRiGmW4omszhaF0RXF520Gx2QIiNX6SPfvtWM/YlmK+inMLzZrseOQgEbp0+Wt02Or0WSK8N0r2B3euCun04NpErsMEYk+ug4JxnAyqGgR5FgHIXsW8DEUMcCTBqgzOZx8GUKIrxcA2TrgGVHbz/iLJVQW3nBdbKFr4dn6YA9ca+7lVr21jfsHD241zX1XRToiTF+w8ewjAM5OZzOj568jRlc+fuPV2by83p+GxhUfcCKcLUtUkY1hvvYK4UsVquoGA+x+GXI12P5A93917DXC6itG5heaWEk+9nKcMpwIRFYtHoVV0BtXy1q/H++B4z7uFkc/yYUlUBJhYP/gEwaXz49BmVrRqqOy9hVTZxfHKajtXYP8CGrFmbVWxVt3F+8fN/RJkfivI4EQV/RBkJNi5KJsM3b+vIF5ZQWl3DQr6Aw6Ov6WivdveQXzJRlL3FgjnB/m/7DTtY/dLZ6F1iAAAAAElFTkSuQmCC'); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="mermaid sequence sample"
        title="mermaid sequence sample"
        src="/static/de0db7db9cc0d256a4a4ee123bf06ed9/a6d36/mermaid-sequence-sample.png"
        srcset="/static/de0db7db9cc0d256a4a4ee123bf06ed9/222b7/mermaid-sequence-sample.png 163w,
/static/de0db7db9cc0d256a4a4ee123bf06ed9/ff46a/mermaid-sequence-sample.png 325w,
/static/de0db7db9cc0d256a4a4ee123bf06ed9/a6d36/mermaid-sequence-sample.png 650w,
/static/de0db7db9cc0d256a4a4ee123bf06ed9/01dae/mermaid-sequence-sample.png 721w"
        sizes="(max-width: 650px) 100vw, 650px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<h2>State Diagrams with Mermaid and WebGraphViz</h2>
<p>In the past when I've wanted to include a simple diagram in a GitHub README file, <a href="https://ardalis.com/simple-flowcharts-and-state-diagrams-with-webgraphviz/">I've used WebGraphViz</a>. More recently, I've used PlantUML for the same kind of thing, as shown <a href="https://github.com/ardalis/CleanArchitecture/issues/103">here</a>. These tools are web-based and text-based, but they're not built into GitHub, so you still need to render images and <a href="https://ardalis.com/add-images-easily-to-github/">add the images to GitHub</a> to reference them. What this meant is that I would typically copy-paste the text somewhere into my repo, perhaps in an issue, and then add the image there as well, and if I ever needed to change the diagram I would copy-paste the text back into the tool, regenerate the image, and do it all over again. It worked but it wasn't ideal.</p>
<p>I have a <a href="https://github.com/ardalis/StatePattern">GitHub sample showing how to implement the State Design Pattern</a> which includes a diagram showing the various states and transitions a model could go through. Originally it used WebGraphViz, but I've updated it now to support Mermaid as well so that you can compare the two.</p>
<p>Here's the original version using WebGraphViz:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 376px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/9016dcceb6108cadcaaea5cf5ea7dcaa/d38a6/state-webgraphviz.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 130.06134969325154%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,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'); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="state-webgraphviz"
        title="state-webgraphviz"
        src="/static/9016dcceb6108cadcaaea5cf5ea7dcaa/d38a6/state-webgraphviz.png"
        srcset="/static/9016dcceb6108cadcaaea5cf5ea7dcaa/222b7/state-webgraphviz.png 163w,
/static/9016dcceb6108cadcaaea5cf5ea7dcaa/ff46a/state-webgraphviz.png 325w,
/static/9016dcceb6108cadcaaea5cf5ea7dcaa/d38a6/state-webgraphviz.png 376w"
        sizes="(max-width: 376px) 100vw, 376px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>And here's the new version using Mermaid (note: the mermaid diagram is using SVG, not a rendered image):</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 650px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/dbd59cbb0a4d19119e959b53a73f06f5/8ae78/mermaid-svg-state-diagram.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 62.576687116564415%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAANCAYAAACpUE5eAAAACXBIWXMAAA7EAAAOxAGVKw4bAAAB7ElEQVQ4y41R227aQBD1Sx8aQgwFc7e9vuO7ISSEkBZL7SMkUaVK0FQh//8TJzNrUYFUNTwczdkzM2dnZ5WRFaCvO6g3uxKXjQ4a7QGuvvQkP+gfgXtUrQdFbfXBYJFNLq7aGBgumtrwbEM2a1A9c4WbDo0cVUpG6QS65Uvzg34OpOHxUxmtnoGh6UpDnpxNjy/8aNqTCbW+KeOniwZMZwzhhmh1Ryf7/JfpsXZi2B0KuTsGmwVxAW+cSv1/050YHghPwSb8IcIdI4gyqYXJBBbp536QUlM7qKmaPDhBIhsN2t84zqWhS1qHVvG5Xu2SayX+8ipWLyVDYftw/AguwbQD4jHtLwDrthdWnPdJ4JxF0zukc557+GxTNIQL0/Kg2Cy4AXx6Yjx7QDJdIM2vEabXiOIMRZphkuWYEookRRLFNH1B+amsSZIcGWkh9fNFiqXrEPoIjhCIsymyYoZVHuJrFuF+kmOZx8ijCL5HE1GNMAyqJxhmxeVZl9GkqDQnGzSnGzSKNdqzJ+jfdhCr3/AefiIqf2G8WGN0s4Y538CdryFu17DuHmERH8yfYd49wWZ9/giHdOXydos6oXazRWuxg/99D6v8A73cQ5SvCH68Se6R5pQvxF/RX+3Ru9+hSxgsd9CXW3SWL9AI7xE+X9liMBJvAAAAAElFTkSuQmCC'); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="mermaid svg state diagram"
        title="mermaid svg state diagram"
        src="/static/dbd59cbb0a4d19119e959b53a73f06f5/a6d36/mermaid-svg-state-diagram.png"
        srcset="/static/dbd59cbb0a4d19119e959b53a73f06f5/222b7/mermaid-svg-state-diagram.png 163w,
/static/dbd59cbb0a4d19119e959b53a73f06f5/ff46a/mermaid-svg-state-diagram.png 325w,
/static/dbd59cbb0a4d19119e959b53a73f06f5/a6d36/mermaid-svg-state-diagram.png 650w,
/static/dbd59cbb0a4d19119e959b53a73f06f5/e548f/mermaid-svg-state-diagram.png 975w,
/static/dbd59cbb0a4d19119e959b53a73f06f5/8ae78/mermaid-svg-state-diagram.png 1096w"
        sizes="(max-width: 650px) 100vw, 650px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>WebGraphViz support colors for their boxes and lines applied directly to the elements. Mermaid supports theming, but I haven't yet tried to implement it. Here's <a href="https://mermaid-js.github.io/mermaid/#/theming?id=here-is-an-example-of-overriding-primarycolor-through-themevariables-and-giving-everything-a-different-look-using-init">an example of using local themes to override the site defaults</a>.</p>
<h2>Summary</h2>
<p>The <a href="https://github.blog/2022-02-14-include-diagrams-markdown-files-mermaid/">announcement from GitHub</a> that they will support mermaid diagrams in their markdown renderer has been met with a lot of developer praise and interest. Additionally, people have commented on similar support in <a href="https://twitter.com/LukejkWarren/status/1493604510387871747">Azure Devops</a>, <a href="https://twitter.com/MrMatthewLayton/status/1493578120129040395">Typora</a>, <a href="https://twitter.com/AngryZoot/status/1493582471207825411">dendron</a>, and <a href="https://twitter.com/C8Luna/status/1493679337752702977">VS Code</a>. It's really catching on, so if you haven't played with it yet, I'd encourage you to do so!</p></div><span><div style="margin-top:2rem"><h4>Tags - <a style="font-size:1rem;color:gray" href="/tags/">Browse all tags</a></h4><ul class="taglist"><li><a href="/tags/github/">github</a></li><li><a href="/tags/mermaid/">mermaid</a></li><li><a href="/tags/markdown/">markdown</a></li><li><a href="/tags/documentation/">documentation</a></li></ul></div></span><span><div style="margin-top:1rem"><h4>Category -  <a style="font-size:1rem;color:gray" href="/category/">Browse all categories</a></h4><ul class="taglist"><li><a href="/category/software-development/">Software Development</a></li></ul></div></span><div class="content has-text-centered"><div class="content-card"><div class="card"><div class="firstinfo"><img src="/static/steve-smith-ardalis-200x200-1530d4270a51c90fda39512d123c2aef.jpg" alt="Steve Smith"/><div class="profileinfo"><h1>About Ardalis</h1><h3>Software Architect</h3><p class="bio">Steve is an experienced software architect and trainer, focusing on code quality and Domain-Driven Design with .NET.</p></div></div></div></div></div><div><div id="disqus_thread"></div></div></div></div></div></article></div></div></div><div><header><div><div class="tile is-parent"><article class="tile is-child box"><div class="sidebar"><div class="content has-text-centered"><div class="content-card"><div class="card-sidebar"><div class="firstinfo"><img src="/static/steve-smith-ardalis-200x200-1530d4270a51c90fda39512d123c2aef.jpg" alt="Steve Smith"/><div class="profileinfo"><h1>About Ardalis</h1><h3>Software Architect</h3><p class="bio">Steve is an experienced software architect and trainer, focusing on code quality and Domain-Driven Design with .NET.</p></div></div></div></div></div><div style="padding:8px;margin-left:10px">Get a <a href="/tips">Free Developer Tip</a> in your inbox every Wednesday.</div><div><h2 style="font-size:22px;padding:7px;margin-left:15px;font-weight:BOLD"><span role="img" aria-label="graduation cap">🎓</span> ONLINE TRAINING</h2></div> <br/><div class="recent-post"><ul class="recent-post"><li><a href="https://www.pluralsight.com/courses/working-c-sharp-generics-best-practices">Working with C# Generics: Best Practices</a> NEW!</li><li><a href="https://www.pluralsight.com/courses/fundamentals-domain-driven-design">Domain-Driven Design Fundamentals</a> NEW!</li><li><a href="https://www.pluralsight.com/courses/refactoring-csharp-developers">Refactoring for C# Devs</a></li><li><a href="https://www.pluralsight.com/courses/kanban-getting-started">Kanban: Getting Started</a></li><li><a href="https://www.pluralsight.com/courses/csharp-solid-principles">SOLID Principles for C# Devs</a></li><li><a href="https://www.pluralsight.com/courses/design-patterns-overview">Design Patterns Overview</a></li></ul></div> <br/><div class="recent-post"><h2 style="font-size:22px;padding:7px;font-weight:BOLD"><span role="img" aria-label="clipboard">📋</span> CATEGORIES</h2> <br/><ul class="recent-post" style="text-transform:uppercase"><li><a href="/category/iraq/">Iraq<!-- --> (<!-- -->157<!-- -->)</a></li><li><a href="/category/personal/">Personal<!-- --> (<!-- -->34<!-- -->)</a></li><li><a href="/category/productivity/">Productivity<!-- --> (<!-- -->158<!-- -->)</a></li><li><a href="/category/security/">Security<!-- --> (<!-- -->7<!-- -->)</a></li><li><a href="/category/software-development/">Software Development<!-- --> (<!-- -->803<!-- -->)</a></li><li><a href="/category/uncategorized/">Uncategorized<!-- --> (<!-- -->548<!-- -->)</a></li></ul> </div><div><br/><h4 style="font-size:22px;padding:7px;margin-left:15px;font-weight:BOLD"><span role="img" aria-label="book">📘</span> FREE ARCHITECTURE EBOOK</h4><br/><center><a href="/architecture-ebook"><img src="/static/Architecture-eBook-Cover-242x300-f5137e850ecde6e104d5b043645cd6b0.png" alt="book"/></a><h4><a href="/architecture-ebook">Get the Book!</a></h4></center><br/><h1 style="font-size:22px;padding:7px;margin-left:15px;font-weight:BOLD"><span role="img" aria-label="pen">🖊️</span> RECENT ARTICLES</h1><br/><div class="columns is-multiline"><div><article><header><div class="recent-post"><ul class="recent-post"><li><a aria-current="page" class="" href="/github-diagrams-with-mermaid/">GitHub Diagrams with Mermaid</a></li></ul></div></header></article></div><div><article><header><div class="recent-post"><ul class="recent-post"><li><a href="/web-api-dto-considerations/">Web API DTO Considerations</a></li></ul></div></header></article></div><div><article><header><div class="recent-post"><ul class="recent-post"><li><a href="/generate-ssh-rsa-keys-windows-wsl/">Generate SSH RSA Key Pairs on Windows with WSL</a></li></ul></div></header></article></div><div><article><header><div class="recent-post"><ul class="recent-post"><li><a href="/guard-clauses-and-exceptions-or-validation/">Guard Clauses and Exceptions or Validation?</a></li></ul></div></header></article></div><div><article><header><div class="recent-post"><ul class="recent-post"><li><a href="/why-use-datetimeoffset/">Why Use DateTimeOffset</a></li></ul></div></header></article></div></div><br/><h1 style="font-size:22px;padding:7px;margin-left:15px;font-weight:BOLD"><span role="img" aria-label="bird">🐦</span> RECENT TWEETS</h1><a class="twitter-timeline" data-width="400" data-height="800" data-theme="light" href="https://twitter.com/ardalis?ref_src=twsrc%5Etfw" data-chrome="noscrollbar">Tweets by ardalis</a><script async="" src="https://platform.twitter.com/widgets.js" charSet="utf-8" type="text/javascript"></script></div><div></div></div></article></div></div></header></div></div></section></div><footer class="footer has-background-black has-text-white-ter"><div class="content has-text-centered has-background-black has-text-white-ter"><div class="container has-background-black has-text-white-ter"><div class="columns"><div class="column is-4"><form action="https://www.google.com/search" method="get"><input type="hidden" name="q" value="site:ardalis.com"/><input type="text" name="q" alt="search" class="googletextbox"/><input type="submit" value="Search my Site with Google" class="googletextbox"/></form><br/></div><div class="column is-4"><div class="content has-text-centered"><img src="data:image/png;base64,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" alt="Ardalis" style="width:5em;height:5em"/><p>Copyright © 2021</p><br/></div></div><div class="column is-4 social"><a title="facebook" href="https://www.facebook.com/StevenAndrewSmith"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHZpZXdCb3g9IjAgMCAyNCAyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj48dGl0bGU+RmFjZWJvb2sgaWNvbjwvdGl0bGU+PHBhdGggZD0iTTIyLjY3NiAwSDEuMzI0Qy41OTMgMCAwIC41OTMgMCAxLjMyNHYyMS4zNTJDMCAyMy40MDguNTkzIDI0IDEuMzI0IDI0aDExLjQ5NHYtOS4yOTRIOS42ODl2LTMuNjIxaDMuMTI5VjguNDFjMC0zLjA5OSAxLjg5NC00Ljc4NSA0LjY1OS00Ljc4NSAxLjMyNSAwIDIuNDY0LjA5NyAyLjc5Ni4xNDF2My4yNGgtMS45MjFjLTEuNSAwLTEuNzkyLjcyMS0xLjc5MiAxLjc3MXYyLjMxMWgzLjU4NGwtLjQ2NSAzLjYzSDE2LjU2VjI0aDYuMTE1Yy43MzMgMCAxLjMyNS0uNTkyIDEuMzI1LTEuMzI0VjEuMzI0QzI0IC41OTMgMjMuNDA4IDAgMjIuNjc2IDAiLz48L3N2Zz4=" alt="Facebook" style="width:1em;height:1em"/></a><a title="linkedin" href="https://www.linkedin.com/in/stevenandrewsmith"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHZpZXdCb3g9IjAgMCAyNCAyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj48dGl0bGU+TGlua2VkSW4gaWNvbjwvdGl0bGU+PHBhdGggZD0iTTIwLjQ0NyAyMC40NTJoLTMuNTU0di01LjU2OWMwLTEuMzI4LS4wMjctMy4wMzctMS44NTItMy4wMzctMS44NTMgMC0yLjEzNiAxLjQ0NS0yLjEzNiAyLjkzOXY1LjY2N0g5LjM1MVY5aDMuNDE0djEuNTYxaC4wNDZjLjQ3Ny0uOSAxLjYzNy0xLjg1IDMuMzctMS44NSAzLjYwMSAwIDQuMjY3IDIuMzcgNC4yNjcgNS40NTV2Ni4yODZ6TTUuMzM3IDcuNDMzYy0xLjE0NCAwLTIuMDYzLS45MjYtMi4wNjMtMi4wNjUgMC0xLjEzOC45Mi0yLjA2MyAyLjA2My0yLjA2MyAxLjE0IDAgMi4wNjQuOTI1IDIuMDY0IDIuMDYzIDAgMS4xMzktLjkyNSAyLjA2NS0yLjA2NCAyLjA2NXptMS43ODIgMTMuMDE5SDMuNTU1VjloMy41NjR2MTEuNDUyek0yMi4yMjUgMEgxLjc3MUMuNzkyIDAgMCAuNzc0IDAgMS43Mjl2MjAuNTQyQzAgMjMuMjI3Ljc5MiAyNCAxLjc3MSAyNGgyMC40NTFDMjMuMiAyNCAyNCAyMy4yMjcgMjQgMjIuMjcxVjEuNzI5QzI0IC43NzQgMjMuMiAwIDIyLjIyMiAwaC4wMDN6Ii8+PC9zdmc+" alt="Linkedin" style="width:1em;height:1em"/></a><a title="twitter" href="https://twitter.com/ardalis"><img class="fas fa-lg" src="data:image/svg+xml;base64,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" alt="Twitter" style="width:1em;height:1em"/></a><a title="youtube" href="https://www.youtube.com/ardalis/"><img src="data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmlld0JveD0iMCAwIDI0IDI0Ij48dGl0bGU+WW91VHViZSBpY29uPC90aXRsZT48cGF0aCBkPSJNMjMuNDk1IDYuMjA1YTMuMDA3IDMuMDA3IDAgMCAwLTIuMDg4LTIuMDg4Yy0xLjg3LS41MDEtOS4zOTYtLjUwMS05LjM5Ni0uNTAxcy03LjUwNy0uMDEtOS4zOTYuNTAxQTMuMDA3IDMuMDA3IDAgMCAwIC41MjcgNi4yMDVhMzEuMjQ3IDMxLjI0NyAwIDAgMC0uNTIyIDUuODA1IDMxLjI0NyAzMS4yNDcgMCAwIDAgLjUyMiA1Ljc4MyAzLjAwNyAzLjAwNyAwIDAgMCAyLjA4OCAyLjA4OGMxLjg2OC41MDIgOS4zOTYuNTAyIDkuMzk2LjUwMnM3LjUwNiAwIDkuMzk2LS41MDJhMy4wMDcgMy4wMDcgMCAwIDAgMi4wODgtMi4wODggMzEuMjQ3IDMxLjI0NyAwIDAgMCAuNS01Ljc4MyAzMS4yNDcgMzEuMjQ3IDAgMCAwLS41LTUuODA1ek05LjYwOSAxNS42MDFWOC40MDhsNi4yNjQgMy42MDJ6Ii8+PC9zdmc+" alt="YoutTube" style="width:1em;height:1em"/></a><a title="github" href="https://github.com/ardalis"><img src="data:image/svg+xml;base64,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" alt="GitHub" style="width:1em;height:1em"/></a></div></div><div class="columns"><div class="column is-12"> <br/></div></div></div></div></footer></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/github-diagrams-with-mermaid/";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"polyfill":["/polyfill-96a8875ca5a8346258da.js"],"app":["/app-d43e6fbc0230c1f5e888.js"],"component---src-pages-404-js":["/component---src-pages-404-js-2cd6b0515398a8f5fa18.js"],"component---src-pages-blog-xxindex-js":["/component---src-pages-blog-xxindex-js-6535ddda14e5d6d30300.js"],"component---src-pages-category-index-js":["/component---src-pages-category-index-js-cf5a6ada83a4cd61f765.js"],"component---src-pages-contact-us-index-js":["/component---src-pages-contact-us-index-js-79d3e7cb0c0b213bd27d.js"],"component---src-pages-contact-us-thanks-js":["/component---src-pages-contact-us-thanks-js-7a344de7f5cf86e1f5f7.js"],"component---src-pages-tags-index-js":["/component---src-pages-tags-index-js-6391f3b51093ba200e77.js"],"component---src-templates-architecture-ebook-page-js":["/component---src-templates-architecture-ebook-page-js-9d1946ec77638eda9260.js"],"component---src-templates-assessments-page-js":["/component---src-templates-assessments-page-js-2ba4de83aef4539b7b7c.js"],"component---src-templates-blog-list-js":["/component---src-templates-blog-list-js-4b5a3be66f7e2fe9828f.js"],"component---src-templates-blog-post-js":["/component---src-templates-blog-post-js-048f5413cb1fff10b611.js"],"component---src-templates-category-js":["/component---src-templates-category-js-c47c5207725dfa9581f4.js"],"component---src-templates-cloud-native-ebook-page-js":["/component---src-templates-cloud-native-ebook-page-js-116e2c66e37a95c994ac.js"],"component---src-templates-index-page-js":["/component---src-templates-index-page-js-1d9c2d913c0311c4cb6d.js"],"component---src-templates-interviews-page-js":["/component---src-templates-interviews-page-js-18cb045682f278127214.js"],"component---src-templates-mentoring-page-js":["/component---src-templates-mentoring-page-js-cb7273e6d53ec3a75bbc.js"],"component---src-templates-porting-ebook-page-js":["/component---src-templates-porting-ebook-page-js-a4dfef4eea5488bc3cee.js"],"component---src-templates-software-craftsmanship-2016-wall-calendar-sponsorship-page-js":["/component---src-templates-software-craftsmanship-2016-wall-calendar-sponsorship-page-js-d0004c44c47a3283bdfa.js"],"component---src-templates-tags-js":["/component---src-templates-tags-js-0af335517450743e19f7.js"],"component---src-templates-tips-page-js":["/component---src-templates-tips-page-js-0c1585caba5b13d87316.js"],"component---src-templates-tools-used-page-js":["/component---src-templates-tools-used-page-js-e588f208f598e34ed6f8.js"],"component---src-templates-training-classes-page-js":["/component---src-templates-training-classes-page-js-2d3a0bc4001bb71b2335.js"]};/*]]>*/</script><script src="/polyfill-96a8875ca5a8346258da.js" nomodule=""></script><script src="/component---src-templates-blog-post-js-048f5413cb1fff10b611.js" async=""></script><script src="/4b5a68188bb98d13639e995513dba2341ec16632-9fd23cd94eed459f68d1.js" async=""></script><script src="/commons-1b32abe377a591af7778.js" async=""></script><script src="/styles-407fe62976dc5310c43e.js" async=""></script><script src="/app-d43e6fbc0230c1f5e888.js" async=""></script><script src="/532a2f07-4651461872a907e7c236.js" async=""></script><script src="/framework-c50c4d43c442b0cfdcd1.js" async=""></script><script src="/webpack-runtime-36388a63b41a7b41a875.js" async=""></script></body></html>